CVE-2025-59270
Low
Description
psPAS PowerShell module does not explicitly enforce TLS 1.2 within the 'Get-PASSAMLResponse' function during the SAML authentication process. An unauthenticated attacker in a 'Man-in-the-Middle' position could manipulate the TLS handshake and downgrade TLS to a deprecated protocol. Fixed in 7.0.209.
SeverityLow
CVSS3.1
Exploit probability15. percentile0.2%
ProductPspete Pspas
PublishedSep 16, 2025
First seenSep 16, 2025
Weakness typeCWE-757CWE-757
How to fix
Update
- pspete pspas7.0.209 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| pspete pspas | 6.4.85 ≤ v < 7.0.209 | 7.0.209 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.