CVE-2025-59328

Medium

Description

A vulnerability in Apache Fory allows a remote attacker to cause a Denial of Service (DoS). The issue stems from the insecure deserialization of untrusted data. An attacker can supply a large, specially crafted data payload that, when processed, consumes an excessive amount of CPU resources during the deserialization process. This leads to CPU exhaustion, rendering the application or system using the Apache Fory library unresponsive and unavailable to legitimate users. Users of Apache Fory are strongly advised to upgrade to version 0.12.2 or later to mitigate this vulnerability. Developers of libraries and applications that depend on Apache Fory should update their dependency requirements to Apache Fory 0.12.2 or later and release new versions of their software.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Fory
PublishedSep 15, 2025
First seenSep 15, 2025

How to fix

Update
  • apache fory0.12.2 or later
  • org.apache.fory:fory-core0.12.2 or later
Vendor advisories

Affected products

ProductAffected versionsFixed in
apache fory0.5.0 ≤ v < 0.12.20.12.2
org.apache.fory:fory-coreMavenv < 0.12.20.12.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-59328 · Apache Fory · Dark Radar