CVE-2025-59337
Medium
Description
Discourse is an open-source community discussion platform. In versions 3.5.0 and below, malicious meta-commands could be embedded in a backup dump and executed during restore. In multisite setups, this allowed an admin of one site to access data or credentials from other sites. This issue is fixed in version 3.5.1.
SeverityMedium
CVSS6.8
Exploit probability—
Product
Discourse
PublishedOct 1, 2025
First seenOct 1, 2025
Weakness typeCWE-77Command injection
How to fix
Update
- discourse discourse3.5.1, 3.6.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| discourse discourse | v < 3.5.1, v < 3.6.0, 3.6.0 | 3.5.1, 3.6.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.