CVE-2025-5934

High

Description

A vulnerability was found in Netgear EX3700 up to 1.0.0.88. It has been classified as critical. Affected is the function sub_41619C of the file /mtd. The manipulation leads to stack-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.0.98 is able to address this issue. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.

SeverityHigh
CVSS8.8
Exploit probability—
ProductNetgear Ex3700 Firmware
PublishedJun 10, 2025
First seenJun 10, 2025

How to fix

Update
  • netgear ex3700_firmware1.0.0.88 or later

Affected products

ProductAffected versionsFixed in
netgear ex3700_firmwarev < 1.0.0.881.0.0.88

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.