CVE-2025-59417

Medium

Description

Lobe Chat is an open-source artificial intelligence chat framework. Prior to version 1.129.4, there is a a cross-site scripting (XSS) vulnerability when handling chat message in lobe-chat that can be escalated to remote code execution on the user’s machine. In lobe-chat, when the response from the server is like <lobeArtifact identifier="ai-new-interpretation" ...> , it will be rendered with the lobeArtifact node, instead of the plain text. However, when the type of the lobeArtifact is image/svg+xml , it will be rendered as the SVGRender component, which internally uses dangerouslySetInnerHTML to set the content of the svg, resulting in XSS attack. Any party capable of injecting content into chat messages, such as hosting a malicious page for prompt injection, operating a compromised MCP server, or leveraging tool integrations, can exploit this vulnerability. This vulnerability is fixed in 1.129.4.

SeverityMedium
CVSS6.1
Exploit probability—
ProductLobehub Lobe Chat
PublishedSep 18, 2025
First seenSep 18, 2025

How to fix

Update
  • lobehub lobe_chat1.129.4 or later
  • @lobehub/chat1.129.4 or later

Affected products

ProductAffected versionsFixed in
lobehub lobe_chatv < 1.129.41.129.4
@lobehub/chatnpmv < 1.129.41.129.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-59417 · Lobehub Lobe Chat · Dark Radar