CVE-2025-59471
Description
A denial of service vulnerability exists in self-hosted Next.js applications that have `remotePatterns` configured for the Image Optimizer. The image optimization endpoint (`/_next/image`) loads external images entirely into memory without enforcing a maximum size limit, allowing an attacker to cause out-of-memory conditions by requesting optimization of arbitrarily large images. This vulnerability requires that `remotePatterns` is configured to allow image optimization from external domains and that the attacker can serve or control a large image on an allowed domain. Strongly consider upgrading to 15.5.10 or 16.1.5 to reduce risk and prevent availability issues in Next applications.
How to fix
- vercel next.js15.5.10, 16.1.5 or later
- next15.5.10, 16.1.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | 10.0.0 ≤ v < 15.5.10, 16.0.0 ≤ v < 16.1.5 | 15.5.10, 16.1.5 |
| nextnpm | 10.0.0 ≤ v < 15.5.10, 15.6.0-canary.0 ≤ v < 16.1.5 | 15.5.10, 16.1.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.