CVE-2025-59527

High

Description

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, a Server-Side Request Forgery (SSRF) vulnerability was discovered in the /api/v1/fetch-links endpoint of the Flowise application. This vulnerability allows an attacker to use the Flowise server as a proxy to access internal network web services and explore their link structures. This issue has been patched in version 3.0.6.

SeverityHigh
CVSS7.5
Exploit probability—
ProductFlowise
PublishedSep 22, 2025
First seenSep 22, 2025

How to fix

Update
  • flowise3.0.6 or later

Affected products

ProductAffected versionsFixed in
flowiseai flowise3.0.5—
flowisenpm3.0.5 ≤ v < 3.0.63.0.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.