CVE-2025-59542

Critical

Description

Chamilo is a learning management system. Prior to version 1.11.34, there is a stored cross-site scripting (XSS) vulnerability. By injecting malicious JavaScript into the course learning path Settings field, an attacker with a low-privileged account (e.g., trainer) can execute arbitrary JavaScript code in the context of any other user viewing the course information page, including administrators. This allows an attacker to exfiltrate sensitive session cookies or tokens, resulting in account takeover (ATO) of higher-privileged users. This issue has been patched in version 1.11.34.

SeverityCritical
CVSS9.0
Exploit probability—
ProductChamilo Lms
PublishedMar 6, 2026
First seenMar 6, 2026

How to fix

Update
  • chamilo chamilo_lms1.11.34 or later

Affected products

ProductAffected versionsFixed in
chamilo chamilo_lmsv < 1.11.341.11.34

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.