CVE-2025-59790

Medium

Description

Improper Privilege Management vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from v2.9.0 through v2.13.0. Users are recommended to upgrade to version 2.14.0, which fixes the issue.

SeverityMedium
CVSS5.4
Exploit probability—
ProductApache Kvrocks
PublishedNov 28, 2025
First seenNov 28, 2025

How to fix

Update
  • apache kvrocks2.14.0 or later

Affected products

ProductAffected versionsFixed in
apache kvrocks2.9.0 ≤ v < 2.14.02.14.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.