CVE-2025-59792
Medium
Description
Reveals plaintext credentials in the MONITOR command vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from 1.0.0 through 2.13.0. Users are recommended to upgrade to version 2.14.0, which fixes the issue.
SeverityMedium
CVSS5.3
Exploit probability—
Product
Apache Kvrocks
PublishedNov 28, 2025
First seenNov 28, 2025
Weakness typeCWE-312CWE-312
How to fix
Update
- apache kvrocks2.14.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache kvrocks | 1.0.0 ≤ v < 2.14.0 | 2.14.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.