CVE-2025-59828

Critical

Description

Claude Code is an agentic coding tool. Prior to Claude Code version 1.0.39, when using Claude Code with Yarn versions 2.0+, Yarn plugins are auto-executed when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins would be executed prior to the user accepting the risks of working in an untrusted directory. Users running Yarn Classic were unaffected by this issue. This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.

SeverityCritical
CVSS9.8
Exploit probability—
ProductAnthropic Claude Code
PublishedSep 24, 2025
First seenSep 24, 2025

How to fix

Update
  • anthropic claude_code1.0.39 or later
  • @anthropic-ai/claude-code1.0.39 or later

Affected products

ProductAffected versionsFixed in
anthropic claude_codev < 1.0.391.0.39
@anthropic-ai/claude-codenpmv < 1.0.391.0.39

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.