CVE-2025-59831

High

Description

git-commiters is a Node.js function module providing committers stats for their git repository. Prior to version 0.1.2, there is a command injection vulnerability in git-commiters. This vulnerability manifests with the library's primary exported API: gitCommiters(options, callback) which allows specifying options such as cwd for current working directory and revisionRange as a revision pointer, such as HEAD. However, the library does not sanitize for user input or practice secure process execution API to separate commands from their arguments and as such, uncontrolled user input is concatenated into command execution. This issue has been patched in version 0.1.2.

SeverityHigh
CVSS8.8
Exploit probability—
ProductRiceball Git-commiters
PublishedSep 25, 2025
First seenSep 25, 2025

How to fix

Update
  • riceball git-commiters0.1.2 or later
  • git-commiters0.1.2 or later

Affected products

ProductAffected versionsFixed in
riceball git-commitersv < 0.1.20.1.2
git-commitersnpmv < 0.1.20.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.