CVE-2025-59840

High

Description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 6.2.0, applications meeting 2 conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. They are vulnerable if they use `vega` in an application that attaches `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window` and if they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). Patches are available in the following Vega applications. If using the latest Vega line (6.x), upgrade to `vega` `6.2.0` / `vega-expression` `6.1.0` / `vega-interpreter` `2.2.1` (if using AST evaluator mode). If using Vega in a non-ESM environment, upgrade to `vega-expression` `5.2.1` / `1.2.1` (if using AST evaluator mode). Some workarounds are available. Do not attach `vega` View instances to global variables, and do not attach `vega` to the global window. These practices of attaching the vega library and View instances may be convenient for debugging, but should not be used in production or in any situation where vega/vega-lite definitions could be provided by untrusted parties.

SeverityHigh
CVSS8.1
Exploit probability—
ProductVega
PublishedNov 13, 2025
First seenNov 13, 2025

How to fix

Update
  • vega6.2.0 or later
  • vega-expression6.1.0, 5.2.1 or later
  • vega-interpreter2.2.1, 1.2.1 or later

Affected products

ProductAffected versionsFixed in
veganpmv < 6.2.06.2.0
vega-expressionnpm6.0.0 ≤ v < 6.1.0, v < 5.2.16.1.0, 5.2.1
vega-interpreternpm2.0.0 ≤ v < 2.2.1, v < 1.2.12.2.1, 1.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.