CVE-2025-59940
Medium
Description
mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.
SeverityMedium
CVSS6.5
Exploit probability—
ProductMkdocs-include-markdown-plugin
PublishedSep 29, 2025
First seenSep 29, 2025
Weakness typeCWE-20Improper input validation
How to fix
Update
- mkdocs-include-markdown-plugin7.1.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| mkdocs-include-markdown-pluginPyPI | v < 7.1.8 | 7.1.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.