CVE-2025-59944

High

Description

Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.

SeverityHigh
CVSS8.0
Exploit probability—
ProductAnysphere Cursor
PublishedOct 3, 2025
First seenOct 3, 2025
Weakness typeCWE-178CWE-178

How to fix

Sources list no fixed version or patch link for this vulnerability.

Affected products

ProductAffected versionsFixed in
anysphere cursorv ≤ 1.6.23—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-59944 · Anysphere Cursor · Dark Radar