CVE-2025-59954
Critical
Description
Knowage is an open source analytics and business intelligence suite. Versions 8.1.26 and below are vulnerable to Remote Code Exection through using an unsafe org.apache.commons.jxpath.JXPathContext in MetaService.java service. This issue is fixed in version 8.1.27.
SeverityCritical
CVSS9.8
Exploit probability—
ProductEng Knowage
PublishedSep 30, 2025
First seenSep 30, 2025
Weakness typeCWE-94Code injection
How to fix
Update
- eng knowage8.1.27 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| eng knowage | v < 8.1.27 | 8.1.27 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.