CVE-2025-6140

Low

Description

A vulnerability, which was classified as problematic, was found in spdlog up to 1.15.1. This affects the function scoped_padder in the library include/spdlog/pattern_formatter-inl.h. The manipulation leads to resource consumption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.15.2 is able to address this issue. The identifier of the patch is 10320184df1eb4638e253a34b1eb44ce78954094. It is recommended to upgrade the affected component.

SeverityLow
CVSS3.3
Exploit probability—
ProductGabime Spdlog
PublishedJun 16, 2025
First seenJun 16, 2025

How to fix

Affected products

ProductAffected versionsFixed in
gabime spdlogv < 1.15.21.15.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-6140 · Gabime Spdlog · Dark Radar