CVE-2025-6167
Medium
Description
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
SeverityMedium
CVSS5.5
Exploit probability—
ProductThemanojdesai Python
PublishedJun 17, 2025
First seenJun 17, 2025
Weakness typeCWE-22Path traversal
How to fix
Update
- python-a2a0.5.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| themanojdesai python_a2a | v ≤ 0.5.5 | — |
| python-a2aPyPI | v < 0.5.6 | 0.5.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.