CVE-2025-61734
High
Description
Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. Users are recommended to upgrade to version 5.0.3, which fixes the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Kylin
PublishedOct 2, 2025
First seenOct 2, 2025
Weakness typeCWE-552CWE-552
How to fix
Update
- apache kylin5.0.3 or later
- org.apache.kylin:kylin5.0.3 or later
- org.apache.kylin:kylin-common-server5.0.3 or later
- org.apache.kylin:kylin-common-service5.0.3 or later
- org.apache.kylin:kylin-core-common5.0.3 or later
- org.apache.kylin:kylin-core-metadata5.0.3 or later
- org.apache.kylin:kylin-ops-server5.0.3 or later
- org.apache.kylin:kylin-server5.0.3 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache kylin | 4.0.0 ≤ v < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylinMaven | 4.0.0 ≤ v < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-common-serverMaven | 4.0.0 ≤ v < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-common-serviceMaven | 4.0.0 ≤ v < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-core-commonMaven | 4.0.0 ≤ v < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-core-metadataMaven | 4.0.0 ≤ v < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-ops-serverMaven | 4.0.0 ≤ v < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-serverMaven | 4.0.0 ≤ v < 5.0.3 | 5.0.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.