CVE-2025-61735

High

Description

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected. Users are recommended to upgrade to version 5.0.3, which fixes the issue.

SeverityHigh
CVSS7.3
Exploit probability—
ProductApache Kylin
PublishedOct 2, 2025
First seenOct 2, 2025

How to fix

Update
  • apache kylin5.0.3 or later
  • org.apache.kylin:kylin5.0.3 or later
  • org.apache.kylin:kylin-common-server5.0.3 or later
  • org.apache.kylin:kylin-common-service5.0.3 or later
  • org.apache.kylin:kylin-core-common5.0.3 or later
  • org.apache.kylin:kylin-core-metadata5.0.3 or later
  • org.apache.kylin:kylin-ops-server5.0.3 or later
  • org.apache.kylin:kylin-server5.0.3 or later

Affected products

ProductAffected versionsFixed in
apache kylin4.0.0 ≤ v < 5.0.35.0.3
org.apache.kylin:kylinMaven4.0.0 ≤ v < 5.0.35.0.3
org.apache.kylin:kylin-common-serverMaven4.0.0 ≤ v < 5.0.35.0.3
org.apache.kylin:kylin-common-serviceMaven4.0.0 ≤ v < 5.0.35.0.3
org.apache.kylin:kylin-core-commonMaven4.0.0 ≤ v < 5.0.35.0.3
org.apache.kylin:kylin-core-metadataMaven4.0.0 ≤ v < 5.0.35.0.3
org.apache.kylin:kylin-ops-serverMaven4.0.0 ≤ v < 5.0.35.0.3
org.apache.kylin:kylin-serverMaven4.0.0 ≤ v < 5.0.35.0.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.