CVE-2025-61915

Medium

Description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

SeverityMedium
CVSS6.0
Exploit probability—
ProductOpenprinting Cups
PublishedNov 29, 2025
First seenNov 29, 2025

How to fix

Update
  • openprinting cups2.4.15 or later

Affected products

ProductAffected versionsFixed in
openprinting cupsv < 2.4.152.4.15

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.