CVE-2025-61924
Low
Description
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
SeverityLow
CVSS3.8
Exploit probability—
Product
Prestashop Checkout
PublishedOct 16, 2025
First seenOct 16, 2025
Weakness typeCWE-184CWE-184
How to fix
Update
- prestashop prestashop_checkout7.4.4.1, 7.5.0.5, 8.4.4.1, 8.5.0.5, 9.5.0.5 or later
- prestashop/ps_checkout4.4.1, 5.0.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| prestashop prestashop_checkout | v < 7.4.4.1, 7.5.0.1 ≤ v < 7.5.0.5, 8.3.1.0 ≤ v < 8.4.4.1, 8.5.0.0 ≤ v < 8.5.0.5, 9.4.3.1 ≤ v < 9.5.0.5 | 7.4.4.1, 7.5.0.5, 8.4.4.1, 8.5.0.5, 9.5.0.5 |
| prestashop/ps_checkoutPackagist | v < 4.4.1, 5.0.0 ≤ v < 5.0.5 | 4.4.1, 5.0.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.