CVE-2025-6209
Description
A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the `encode_image` function in `generic_utils.py`. This vulnerability allows an attacker to manipulate the `image_path` input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files outside the intended directory. The vulnerability is fixed in version 0.12.41.
How to fix
- llamaindex llamaindex0.12.41 or later
- llama-index-core0.12.41 or later
- llama-index0.12.41 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| llamaindex llamaindex | 0.12.27 ≤ v < 0.12.41 | 0.12.41 |
| llama-index-corePyPI | 0.11.23 ≤ v < 0.12.41 | 0.12.41 |
| llama-indexPyPI | 0.12.27 ≤ v < 0.12.41 | 0.12.41 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.