CVE-2025-6210

Medium

Description

A vulnerability in the ObsidianReader class of the run-llama/llama_index repository, specifically in version 0.12.27, allows for hardlink-based path traversal. This flaw permits attackers to bypass path restrictions and access sensitive system files, such as /etc/passwd, by exploiting hardlinks. The vulnerability arises from inadequate handling of hardlinks in the load_data() method, where the security checks fail to differentiate between real files and hardlinks. This issue is resolved in version 0.5.2.

SeverityMedium
CVSS6.2
Exploit probability—
ProductLlamaindex
PublishedJul 7, 2025
First seenJul 7, 2025

How to fix

Update
  • llamaindex llamaindex0.5.2 or later
  • llama-index-readers-obsidian0.5.2 or later
  • llama-index0.5.2 or later

Affected products

ProductAffected versionsFixed in
llamaindex llamaindexv < 0.5.20.5.2
llama-index-readers-obsidianPyPIv < 0.5.20.5.2
llama-indexPyPIv < 0.5.20.5.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.