CVE-2025-62161
Critical
Description
Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.
SeverityCritical
CVSS10.0
Exploit probability—
ProductYouki
PublishedNov 6, 2025
First seenNov 6, 2025
Weakness typeCWE-363CWE-363CWE-61CWE-61
How to fix
Update
- youki-dev youki0.5.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| youki-dev youki | v < 0.5.7 | 0.5.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.