CVE-2025-62164

High

Description

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.

SeverityHigh
CVSS8.8
Exploit probability—
ProductVllm
PublishedNov 21, 2025
First seenNov 21, 2025

How to fix

Update
  • vllm vllm0.11.1 or later
  • vllm0.11.1 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.10.2 ≤ v < 0.11.1, 0.11.10.11.1
vllmPyPI0.10.2 ≤ v < 0.11.10.11.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.