CVE-2025-62188
Description
An Exposure of Sensitive Information to an Unauthorized Actor vulnerability exists in Apache DolphinScheduler. This vulnerability may allow unauthorized actors to access sensitive information, including database credentials. This issue affects Apache DolphinScheduler versions 3.1.*. Users are recommended to upgrade to: * version ≥ 3.2.0 if using 3.1.x As a temporary workaround, users who cannot upgrade immediately may restrict the exposed management endpoints by setting the following environment variable: ``` MANAGEMENT_ENDPOINTS_WEB_EXPOSURE_INCLUDE=health,metrics,prometheus ``` Alternatively, add the following configuration to the application.yaml file: ``` management: endpoints: web: exposure: include: health,metrics,prometheus ``` This issue has been reported as CVE-2023-48796: https://cveprocess.apache.org/cve5/CVE-2023-48796
How to fix
- apache dolphinscheduler3.2.0 or later
- org.apache.dolphinscheduler:dolphinscheduler3.2.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache dolphinscheduler | 3.1.0 ≤ v < 3.2.0 | 3.2.0 |
| org.apache.dolphinscheduler:dolphinschedulerMaven | 3.1.0 ≤ v < 3.2.0 | 3.2.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.