CVE-2025-62228
High
Description
Apache Flink CDC version 3.4.0 was vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, we recommend users update Flink CDC version to 3.5.0 which address this issue.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Apache Flink Cdc
PublishedOct 9, 2025
First seenOct 9, 2025
Weakness typeCWE-89SQL injection
How to fix
Update
- org.apache.flink:flink-cdc-pipeline-connectors3.5.0 or later
- org.apache.flink:flink-connector-oracle-cdc3.5.0 or later
- org.apache.flink:flink-connector-db2-cdc3.5.0 or later
- org.apache.flink:flink-connector-sqlserver-cdc3.5.0 or later
- org.apache.flink:flink-connector-mysql-cdc3.5.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache flink_cdc | 3.4.0 | — |
| org.apache.flink:flink-cdc-pipeline-connectorsMaven | 3.0.0 ≤ v < 3.5.0 | 3.5.0 |
| org.apache.flink:flink-connector-oracle-cdcMaven | 3.0.0 ≤ v < 3.5.0 | 3.5.0 |
| org.apache.flink:flink-connector-db2-cdcMaven | 3.0.0 ≤ v < 3.5.0 | 3.5.0 |
| org.apache.flink:flink-connector-sqlserver-cdcMaven | 3.0.0 ≤ v < 3.5.0 | 3.5.0 |
| org.apache.flink:flink-connector-mysql-cdcMaven | 3.0.0 ≤ v < 3.5.0 | 3.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.