CVE-2025-62235
High
Description
Authentication Bypass by Spoofing vulnerability in Apache NimBLE. Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0. Users are recommended to upgrade to version 1.9.0, which fixes the issue.
SeverityHigh
CVSS8.1
Exploit probability—
Product
Apache Nimble
PublishedJan 10, 2026
First seenJan 10, 2026
Weakness typeCWE-290CWE-290
How to fix
Update
- apache nimble1.9.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache nimble | v < 1.9.0 | 1.9.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.