CVE-2025-62254
Description
The ComboServlet in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.2, 2023.Q3.1 through 2023.Q3.5, 7.4 GA through update 92, 7.3 GA through update 35, and older unsupported versions does not limit the number or size of the files it will combine, which allows remote attackers to create very large responses that lead to a denial of service attack via the URL query string.
How to fix
- com.liferay.portal:com.liferay.portal.impl97.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| liferay liferay_portal | 7.4.0 ≤ v ≤ 7.4.3.111 | — |
| liferay digital_experience_platform | 7.3, 7.4, 2023.q3.1, 2023.q3.2, 2023.q3.3, 2023.q3.4, 2023.q3.5, 2023.q4.0, 2023.q4.1, 2023.q4.2 | — |
| com.liferay.portal:com.liferay.portal.implMaven | v < 97.0.0 | 97.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.