CVE-2025-62265
Description
Cross-site scripting (XSS) vulnerability in the Blogs widget in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.8, 7.4 GA through update 92, 7.3 GA through update 36, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via a crafted <iframe> injected into a blog entry's “Content” text field The Blogs widget in Liferay DXP does not add the sandbox attribute to <iframe> elements, which allows remote attackers to access the parent page via scripts and links in the frame page.
How to fix
- liferay liferay_portal7.4.3.112 or later
- com.liferay.portal:release.portal.bom7.4.3.112-ga112 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| liferay liferay_portal | 7.2.0 ≤ v < 7.4.3.112 | 7.4.3.112 |
| liferay digital_experience_platform | v ≤ 7.4, 2023.q3.1, 2023.q3.2, 2023.q3.3, 2023.q3.4, 2023.q3.5, 2023.q3.6, 2023.q3.7, 2023.q3.8, 2023.q4.0, 2023.q4.1, 2023.q4.2, 2023.q4.3, 2023.q4.4, 2023.q4.5, 2023.q4.6, 2023.q4.7, 2023.q4.8, 2023.q4.9, 2023.q4.10 | — |
| com.liferay.portal:release.portal.bomMaven | 7.4.0-ga1 ≤ v < 7.4.3.112-ga112 | 7.4.3.112-ga112 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.