CVE-2025-62372

Medium

Description

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

SeverityMedium
CVSS6.5
Exploit probability—
ProductVllm
PublishedNov 21, 2025
First seenNov 21, 2025
Weakness typeCWE-129CWE-129

How to fix

Update
  • vllm vllm0.11.1 or later
  • vllm0.11.1 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.5.5 ≤ v < 0.11.1, 0.11.10.11.1
vllmPyPI0.5.5 ≤ v < 0.11.10.11.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.