CVE-2025-62412
Low
Description
LibreNMS is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts > Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.
SeverityLow
CVSS3.8
Exploit probability20. percentile0.3%
ProductLibrenms
PublishedOct 16, 2025
First seenOct 16, 2025
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- librenms librenms25.10.0 or later
- librenms/librenms25.10.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| librenms librenms | 25.8.0 ≤ v < 25.10.0 | 25.10.0 |
| librenms/librenmsPackagist | v < 25.10.0 | 25.10.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.