CVE-2025-62422
High
Description
DataEase is an open source data visualization and analytics platform. In versions 2.10.13 and earlier, the /de2api/datasetData/tableField interface is vulnerable to SQL injection. An attacker can construct a malicious tableName parameter to execute arbitrary SQL commands. This issue is fixed in version 2.10.14. No known workarounds exist.
SeverityHigh
CVSS8.8
Exploit probability—
ProductDataease
PublishedOct 17, 2025
First seenOct 17, 2025
Weakness typeCWE-89SQL injection
How to fix
Update
- dataease dataease2.10.14 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| dataease dataease | v < 2.10.14 | 2.10.14 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.