CVE-2025-62426

Medium

Description

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, the /v1/chat/completions and /tokenize endpoints allow a chat_template_kwargs request parameter that is used in the code before it is properly validated against the chat template. With the right chat_template_kwargs parameters, it is possible to block processing of the API server for long periods of time, delaying all other requests. This issue has been patched in version 0.11.1.

SeverityMedium
CVSS6.5
Exploit probability—
ProductVllm
PublishedNov 21, 2025
First seenNov 21, 2025

How to fix

Update
  • vllm vllm0.11.1 or later
  • vllm0.11.1 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.5.5 ≤ v < 0.11.1, 0.11.10.11.1
vllmPyPI0.5.5 ≤ v < 0.11.10.11.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.