CVE-2025-62519

High

Description

phpMyFAQ is an open source FAQ web application. Prior to version 4.0.14, an authenticated SQL injection vulnerability in the main configuration update functionality of phpMyFAQ allows a privileged user with 'Configuration Edit' permissions to execute arbitrary SQL commands. Successful exploitation can lead to a full compromise of the database, including reading, modifying, or deleting all data, as well as potential remote code execution depending on the database configuration. This issue has been patched in version 4.0.14.

SeverityHigh
CVSS7.2
Exploit probability—
ProductPhpmyfaq
PublishedNov 17, 2025
First seenNov 17, 2025
Weakness typeCWE-89SQL injection

How to fix

Update
  • phpmyfaq phpmyfaq4.0.14 or later
  • thorsten/phpmyfaq4.0.14 or later
  • phpmyfaq/phpmyfaq4.0.14 or later

Affected products

ProductAffected versionsFixed in
phpmyfaq phpmyfaqv < 4.0.144.0.14
thorsten/phpmyfaqPackagistv < 4.0.144.0.14
phpmyfaq/phpmyfaqPackagistv < 4.0.144.0.14

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-62519 · Phpmyfaq · Dark Radar