CVE-2025-62722

Medium

Description

LinkAce is a self-hosted archive to collect website links. In versions 2.3.1 and below, the social media sharing functionality contains a Stored Cross-Site Scripting (XSS) vulnerability that allows any authenticated user to inject arbitrary JavaScript by creating a link with malicious HTML in the title field. When a user views the link details page and the shareable links are rendered, the malicious JavaScript executes in their browser. This vulnerability affects multiple sharing services and can be exploited to steal session cookies, perform actions on behalf of users, or deliver malware. This issue is fixed in version 2.4.0.

SeverityMedium
CVSS5.4
Exploit probability—
ProductLinkace
PublishedNov 4, 2025
First seenNov 4, 2025

How to fix

Update
  • linkace linkace2.4.0 or later

Affected products

ProductAffected versionsFixed in
linkace linkacev < 2.4.02.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.