CVE-2025-62728

Medium

Description

SQL injection vulnerability in Hive Metastore Server (HMS) when processing delete column statistics requests via the Thrift APIs. The vulnerability is only exploitable by trusted/authorized users/applications that are allowed to call directly the Thrift APIs. In most real-world deployments, HMS is accessible to only a handful of applications (e.g., Hiveserver2) thus the vulnerability is not exploitable. Moreover, the vulnerable code cannot be reached when metastore.try.direct.sql property is set to false. This issue affects Apache Hive: from 4.1.0 before 4.2.0. Users are recommended to upgrade to version 4.2.0, which fixes the issue. Users who cannot upgrade directly are encouraged to set metastore.try.direct.sql property to false if the HMS Thrift APIs are exposed to general public.

SeverityMedium
CVSS5.4
Exploit probability—
ProductApache Hive
PublishedNov 26, 2025
First seenNov 26, 2025
Weakness typeCWE-89SQL injection

How to fix

Update
  • org.apache.hive:hive-common4.2.0 or later
  • org.apache.hive:hive-metastore4.2.0 or later

Affected products

ProductAffected versionsFixed in
apache hive4.1.0—
org.apache.hive:hive-commonMaven4.1.0 ≤ v < 4.2.04.2.0
org.apache.hive:hive-metastoreMaven4.1.0 ≤ v < 4.2.04.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.