CVE-2025-62795
Description
JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to v3.10.21-lts and v4.10.12-lts, a low-privileged authenticated user can invoke LDAP configuration tests and start LDAP synchronization by sending crafted messages to the /ws/ldap/ WebSocket endpoint, bypassing authorization checks and potentially exposing LDAP credentials or causing unintended sync operations. This vulnerability is fixed in v3.10.21-lts and v4.10.12-lts.
How to fix
- fit2cloud jumpserver3.10.21, 4.10.12 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| fit2cloud jumpserver | v < 3.10.21, 4.0.0 ≤ v < 4.10.12 | 3.10.21, 4.10.12 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.