CVE-2025-64107

High

Description

Cursor is a code editor built for programming with AI. In versions 1.7.52 and below, manipulating internal settings may lead to RCE. Cursor detects path manipulation via forward slashes (./.cursor/./././././mcp.json etc.), and requires human approval to complete the operation. However, the same kind of manipulation using backslashes was not correctly detected, allowing an attacker who had already achieved prompt injection or some other level of control to overwrite sensitive editor files without approval on Windows machines. This issue is fixed in version 2.0.

SeverityHigh
CVSS8.8
Exploit probability—
ProductAnysphere Cursor
PublishedNov 4, 2025
First seenNov 4, 2025

How to fix

Update
  • anysphere cursor2.0 or later

Affected products

ProductAffected versionsFixed in
anysphere cursorv < 2.02.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.