CVE-2025-64108

High

Description

Cursor is a code editor built for programming with AI. In versions 1.7.44 and below, various NTFS path quirks allow a prompt injection attacker to circumvent sensitive file protections and overwrite files which Cursor requires human approval to overwrite. Modification of some of the protected files can lead to RCE. Must be chained with a prompt injection or malicious model attach. Only affects systems supporting NTFS. This issue is fixed in version 2.0.

SeverityHigh
CVSS8.8
Exploit probability—
ProductAnysphere Cursor
PublishedNov 4, 2025
First seenNov 4, 2025

How to fix

Update
  • anysphere cursor2.0 or later

Affected products

ProductAffected versionsFixed in
anysphere cursorv < 2.02.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.