CVE-2025-64110

High

Description

Cursor is a code editor built for programming with AI. In versions 1.7.23 and below, a logic bug allows a malicious agent to read sensitive files that should be protected via cursorignore. An attacker who has already achieved prompt injection, or a malicious model, could create a new cursorignore file which can invalidate the configuration of pre-existing ones. This could allow a malicious agent to read protected files. This issue is fixed in version 2.0.

SeverityHigh
CVSS7.5
Exploit probability—
ProductAnysphere Cursor
PublishedNov 5, 2025
First seenNov 5, 2025

How to fix

Update
  • anysphere cursor2.0 or later

Affected products

ProductAffected versionsFixed in
anysphere cursorv < 2.02.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-64110 · Anysphere Cursor · Dark Radar