CVE-2025-64174

Medium

Description

Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside app/code/core/Mage/Adminhtml/Block/Notification/Grid/Renderer/Actions.php. A malicious translation or polluted data can inject script. This issue is fixed in version 20.16.0.

SeverityMedium
CVSS4.8
Exploit probability—
ProductOpenmage Magento
PublishedNov 6, 2025
First seenNov 6, 2025

How to fix

Update
  • openmage magento20.16.0 or later
  • openmage/magento-lts20.16.0 or later

Affected products

ProductAffected versionsFixed in
openmage magentov < 20.16.020.16.0
openmage/magento-ltsPackagistv < 20.16.020.16.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-64174 · Openmage Magento · Dark Radar