CVE-2025-64175
Description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, Gogs’ 2FA recovery code validation does not scope codes by user, enabling cross-account bypass. If an attacker knows a victim’s username and password, they can use any unused recovery code (e.g., from their own account) to bypass the victim’s 2FA. This enables full account takeover and renders 2FA ineffective in all environments where it's enabled.. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
How to fix
- gogs gogs0.13.4 or later
- gogs.io/gogs0.13.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| gogs gogs | v < 0.13.4 | 0.13.4 |
| gogs.io/gogsGo | 0.11.19 ≤ v < 0.13.4, 0.11.19 ≤ v | 0.13.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.