CVE-2025-64408
Description
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges. This issue affects all current versions. Users are recommended to upgrade to version 3.5.0, which fixes the issue.
How to fix
- apache causeway3.5.0 or later
- org.apache.causeway.commons:causeway-commons3.5.0 or later
- org.apache.causeway.core:causeway-applib3.5.0 or later
- org.apache.causeway.core:causeway-core3.5.0 or later
- org.apache.causeway.viewer:causeway-viewer-wicket3.5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache causeway | 2.0.0 ≤ v < 3.5.0, 4.0.0 | 3.5.0 |
| org.apache.causeway.commons:causeway-commonsMaven | v < 3.5.0 | 3.5.0 |
| org.apache.causeway.core:causeway-applibMaven | v < 3.5.0 | 3.5.0 |
| org.apache.causeway.core:causeway-coreMaven | v < 3.5.0 | 3.5.0 |
| org.apache.causeway.viewer:causeway-viewer-wicketMaven | v < 3.5.0 | 3.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.