CVE-2025-64428
Critical
Description
Dataease is an open source data visualization analysis tool. Versions prior to 2.10.17 are vulnerable to JNDI injection. A blacklist was added in the patch for version 2.10.14. However, JNDI injection remains possible via the iiop, corbaname, and iiopname schemes. The vulnerability has been fixed in version 2.10.17.
SeverityCritical
CVSS9.8
Exploit probability—
ProductDataease
PublishedNov 20, 2025
First seenNov 20, 2025
Weakness typeCWE-74Injection
How to fix
Update
- dataease dataease2.10.17 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| dataease dataease | v < 2.10.17 | 2.10.17 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.