CVE-2025-64751
Description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.
How to fix
- openfga helm_charts0.2.49 or later
- openfga openfga1.11.1 or later
- github.com/openfga/openfga1.11.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| openfga helm_charts | 0.1.34 ≤ v < 0.2.49 | 0.2.49 |
| openfga openfga | 1.4.0 ≤ v < 1.11.1 | 1.11.1 |
| github.com/openfga/openfgaGo | 1.4.0 ≤ v < 1.11.1 | 1.11.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.