CVE-2025-65012
Description
Kirby is an open-source content management system. From versions 5.0.0 to 5.1.3, attackers could change the title of any page or the name of any user to a malicious string. Then they could modify any content field of the same model without saving, making the model a candidate for display in the "Changes" dialog. If another authenticated user subsequently opened the dialog in their Panel, the malicious code would be executed. This vulnerability affects all Kirby 5 sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update page titles or usernames. The attack requires user interaction by another Panel user and cannot be automated. This issue has been patched in version 5.1.4.
How to fix
- getkirby kirby5.1.4 or later
- getkirby/cms5.1.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| getkirby kirby | 5.0.0 ≤ v < 5.1.4 | 5.1.4 |
| getkirby/cmsPackagist | 5.0.0 ≤ v < 5.1.4 | 5.1.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.