CVE-2025-65082
Description
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.
How to fix
- apache http_server2.4.66 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache http_server | 2.4.0 ≤ v < 2.4.66 | 2.4.66 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.