CVE-2025-65106

High

Description

LangChain is a framework for building agents and LLM-powered applications. From versions 0.3.79 and prior and 1.0.0 to 1.0.6, a template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template syntax. This vulnerability affects applications that accept untrusted template strings (not just template variables) in ChatPromptTemplate and related prompt template classes. This issue has been patched in versions 0.3.80 and 1.0.7.

SeverityHigh
CVSS8.3
Exploit probability—
ProductLangchain-core
PublishedNov 21, 2025
First seenNov 21, 2025
Weakness typeCWE-1336CWE-1336

How to fix

Update
  • langchain-core1.0.7, 0.3.80 or later

Affected products

ProductAffected versionsFixed in
langchain-corePyPI1.0.0 ≤ v < 1.0.7, v < 0.3.801.0.7, 0.3.80

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-65106 · Langchain-core · Dark Radar